summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-11-23 12:42:05 -0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-16 08:01:48 -0800
commit6087c246c4c2ff1c7bdfb80bfabda39df845405c (patch)
tree52388ff273b82853127e4b72db02df8cf1359b88 /CMakeLists.txt
parent30999a6898849ddcee829f3081532fe8369c2b45 (diff)
downloadsubsurface-6087c246c4c2ff1c7bdfb80bfabda39df845405c.tar.gz
Read the translations from the translations file
instead of hardcoding everything on the main cmake Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 904bab29a..1388d3686 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -302,20 +302,7 @@ set(DOCFILES
${CMAKE_BINARY_DIR}/Documentation/user-manual_ru.html
)
-set(QTTRANSLATIONS_BASE
- qt_da.qm
- qt_de.qm
- qt_es.qm
- qt_fr.qm
- qt_he.qm
- qt_hu.qm
- qt_pl.qm
- qt_pt.qm
- qt_ru.qm
- qt_sk.qm
- qt_sv.qm
- qt_zh_TW.qm
-)
+FILE(READ "subsurface_enabled_translations" QTTRANSLATIONS_BASE)
if(NOT DEFINED QT_TRANSLATION_DIR OR QT_TRANSLATION_DIR STREQUAL "")
set(QT_TRANSLATION_DIR ${Qt5Core_DIR}/../../../translations)