summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Lubomir I. Ivanov <neolit123@gmail.com>2015-04-18 15:22:10 +0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-18 08:01:14 -0700
commit8c4ef161b22818b7dd4d40d3b8e0faf84eb5b4d8 (patch)
treed7eee60a363cb8725355b8f9c284e9d6ec646b50 /CMakeLists.txt
parentcdd84bb1886680480428e11b2cea7b4b7a1c5d7f (diff)
downloadsubsurface-8c4ef161b22818b7dd4d40d3b8e0faf84eb5b4d8.tar.gz
cmake: generate clean ssrf-version.h
remoevs the extra white sapce in the generated ssrf-version.h. Signed-off-by: Lubomir I. Ivanov <neolit123@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 70cfabbeb..8ceac9a15 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,10 +88,10 @@ SET(QT_TEST_LIBRARIES ${QT_LIBRARIES} Qt5::Test)
# Generate the ssrf-config.h every 'make'
-FILE(WRITE ${CMAKE_BINARY_DIR}/version.h.in "
- #define VERSION_STRING \"@VERSION_STRING@\"
- #define GIT_VERSION_STRING \"@GIT_VERSION_STRING@\"
- #define CANONICAL_VERSION_STRING \"@CANONICAL_VERSION_STRING@\"
+FILE(WRITE ${CMAKE_BINARY_DIR}/version.h.in
+"#define VERSION_STRING \"@VERSION_STRING@\"
+#define GIT_VERSION_STRING \"@GIT_VERSION_STRING@\"
+#define CANONICAL_VERSION_STRING \"@CANONICAL_VERSION_STRING@\"
")
FILE(WRITE ${CMAKE_BINARY_DIR}/version.cmake "