summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Lubomir I. Ivanov <neolit123@gmail.com>2015-04-18 15:22:13 +0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-18 08:02:23 -0700
commit8fec4ab5e760a3d958a436d2f170a5a7e67e055e (patch)
tree40634814fe42beebdd04c222abd46ae32a1694f6 /CMakeLists.txt
parent8153c1560b64dead437aee854b610522e54768fe (diff)
downloadsubsurface-8fec4ab5e760a3d958a436d2f170a5a7e67e055e.tar.gz
cmake: use uppercase for defined macros
Signed-off-by: Lubomir I. Ivanov <neolit123@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 5 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ecf91f1b4..e0b397b9e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -359,7 +359,7 @@ endif()
# QTest based tests
-macro(test NAME FILE)
+macro(TEST NAME FILE)
add_executable(${NAME} tests/${FILE} ${SUBSURFACE_RESOURCES})
target_link_libraries(${NAME} subsurface_corelib ${QT_TEST_LIBRARIES} ${SUBSURFACE_LINK_LIBRARIES})
add_test(NAME ${NAME} COMMAND ${NAME})
@@ -369,10 +369,10 @@ enable_testing()
add_definitions(-DSUBSURFACE_SOURCE="${CMAKE_SOURCE_DIR}")
add_definitions(-g)
if(NOT NO_TESTS)
- test(TestUnitConversion testunitconversion.cpp)
- test(TestProfile testprofile.cpp)
- test(TestGpsCoords testgpscoords.cpp)
- test(TestParse testparse.cpp)
+ TEST(TestUnitConversion testunitconversion.cpp)
+ TEST(TestProfile testprofile.cpp)
+ TEST(TestGpsCoords testgpscoords.cpp)
+ TEST(TestParse testparse.cpp)
endif()
if(NOT NO_DOCS)