summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-04-09 14:18:30 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-09 11:16:30 -0700
commita56c0f227d3e8d73ba2721a3598e406e2ff1c4d8 (patch)
tree30a64c7d150db0f3508ef547550cba273cf9b292 /CMakeLists.txt
parent3a06bb37d4b23b15d453da031ed5d7eb56bc65b9 (diff)
downloadsubsurface-a56c0f227d3e8d73ba2721a3598e406e2ff1c4d8.tar.gz
We use static library if we find - option was not being used.
Currently we search for a static library and if we don't find it, we search for a shared library. If one of them is found, we return success but if none of them is found, error. So - A static library for libgit and libdivecomputer is preferred over the shared one. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b53a55585..35a2d8b77 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,8 +8,6 @@ cmake_minimum_required(VERSION 2.8.11)
SET(CMAKE_AUTOMOC ON)
SET(CMAKE_AUTOUIC ON)
OPTION(PREFER_GIT_FROMSOURCE "Turn off if you wanna use system's libgit 0.21.5" ON)
-OPTION(PREFER_GIT_STATIC "Turn off if you wanna use a shared library" ON)
-OPTION(PREFER_LIBDC_STATIC "Turn off if you wanna use a shared library" ON)
SET(CMAKE_MODULE_PATH ${${PROJECT_NAME}_SOURCE_DIR}/cmake/Modules)
INCLUDE_DIRECTORIES( . ${CMAKE_CURRENT_BINARY_DIR} ${CMAKE_BINARY_DIR} qt-ui qt-ui/profile)