summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-06-30 16:55:53 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-06-30 16:55:53 -0700
commit4604b6a8de4daa31c2be406a66dab9dc3b0435e7 (patch)
tree9500dce99138c83815309caff172b2ee36c0ca99 /CMakeLists.txt
parent61fff71391ceef0840dadc95f78b586e6f2be6a3 (diff)
downloadsubsurface-4604b6a8de4daa31c2be406a66dab9dc3b0435e7.tar.gz
BLE: require Qt 5.6 and suggest Qt 5.9.1
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 11 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0f75e47b6..6ed2e08b7 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -216,9 +216,18 @@ if (BTSUPPORT AND "${Qt5Core_VERSION}" VERSION_LESS 5.4.0)
list(REMOVE_ITEM QT_LIBRARIES Qt5::Bluetooth)
endif()
-#I can't test MacOS, and Windows Qt doesn't support BLE at all afaik
+# Windows Qt doesn't support BLE at all
+# Mac hasn't been tested, yet - so far it's disabled
+# the rest of them need at least 5.6 to be reasonable but really, you want 5.9.1
if (BTSUPPORT AND (ANDROID OR CMAKE_SYSTEM_NAME STREQUAL "Linux"))
- set(BLESUPPORT ON)
+ if ("${Qt5Core_VERSION}" VERSION_LESS 5.6.0)
+ message(STATUS "Turning off BLE support as Qt version ${Qt5Core_VERSION} is insufficient for that")
+ else()
+ set(BLESUPPORT ON)
+ if ("${Qt5Core_VERSION}" VERSION_LESS 5.9.1)
+ message(STATUS "BLE support has been enabled, but for best results you really want Qt 5.9.1")
+ endif()
+ endif()
endif()
if(BTSUPPORT)