summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-03-22 20:47:33 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-27 07:36:33 -0700
commit5ad52db451102151b58b0e9b2af1adb80d16105d (patch)
tree5b3b37dc0a840311929a5abc465ec7d2f06d639f /CMakeLists.txt
parent643a964d099b2bac29500dcd70aaec3ee3e9b0bd (diff)
downloadsubsurface-5ad52db451102151b58b0e9b2af1adb80d16105d.tar.gz
drop support for Qt 5.4 and before
The oldest version tested on TravisCI is Qt 5.5, which is also what is in Ubuntu 16.04. Drop all the older cruft, noone should use that anymore. Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 1 insertions, 11 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aa827ab79..432030354 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -230,22 +230,12 @@ if(ANDROID)
set(CMAKE_FIND_ROOT_PATH "/;${CMAKE_FIND_ROOT_PATH}")
endif()
set(QT_FIND_COMPONENTS Core Concurrent Widgets Network Svg Positioning Quick Location ${QT_EXTRA_COMPONENTS})
-find_package(Qt5 REQUIRED COMPONENTS ${QT_FIND_COMPONENTS} LinguistTools Test QuickTest)
+find_package(Qt5 5.5 REQUIRED COMPONENTS ${QT_FIND_COMPONENTS} LinguistTools Test QuickTest)
foreach(_QT_COMPONENT ${QT_FIND_COMPONENTS})
list(APPEND QT_LIBRARIES Qt5::${_QT_COMPONENT})
endforeach()
set(QT_TEST_LIBRARIES ${QT_LIBRARIES} Qt5::Test Qt5::QuickTest)
-#disable bluetooth if Qt version is ancient.
-if (BTSUPPORT AND Qt5Widgets_VERSION VERSION_LESS 5.4.0)
- if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
- message(FATAL_ERROR "Subsurface-mobile requires BT and Qt version ${Qt5Widgets_VERSION} is too old for that")
- endif()
- set(BTSUPPORT OFF)
- message(STATUS "Turning off Bluetooth support as Qt version ${Qt5Core_VERSION} is insufficient for that")
- list(REMOVE_ITEM QT_LIBRARIES Qt5::Bluetooth)
-endif()
-
# Windows Qt doesn't support BLE at all
# the rest of them need at least 5.6 to be reasonable but really, you want 5.9.1
if (BTSUPPORT AND NOT CMAKE_SYSTEM_NAME STREQUAL "Windows")