summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2015-04-07 17:49:10 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-07 16:27:39 -0700
commit6f935907053a6f2cc97b1fafed4a6896d40f6874 (patch)
tree93fe671600a3ffdd655c96f7442d3c3deb2761db /CMakeLists.txt
parent8b2ba50a629522b33ec69281ecf43fe5dc0dbedf (diff)
downloadsubsurface-6f935907053a6f2cc97b1fafed4a6896d40f6874.tar.gz
Add FindLibdivecomputer.cmake
Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 1 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 329a5e19b..74accf273 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -38,20 +38,7 @@ ELSE()
INCLUDE_DIRECTORIES(${LIBGIT2_INCLUDE_DIRS})
ENDIF()
-SET(LIBDCDEVEL "" CACHE STRING "libraries")
-IF(DEFINED LIBDCDEVEL)
- cmake_policy(SET CMP0015 OLD)
- include_directories(${LIBDCDEVEL}/include )
- link_directories(${LIBDCDEVEL}/src/.libs)
- if(NOT DEFINED LIBDCSTATIC)
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -ldivecomputer -lusb-1.0)
- ELSE()
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} libdivecomputer.a -lusb-1.0)
- ENDIF()
-ELSE()
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -ldivecomputer)
-ENDIF()
-
+FIND_PACKAGE(Libdivecomputer REQUIRED)
FIND_PACKAGE(Marble REQUIRED)
include_directories(${MARBLE_INCLUDE_DIR})