summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar jan Iversen <jan@casacondor.com>2019-11-23 11:24:26 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-11-26 09:44:13 -0800
commitb4b4e7872bb3078166a4b7519d26ca0828105ce4 (patch)
tree79be93b97018431833a2f75c69ae9073b90e7dfa /CMakeLists.txt
parent1b058d58f7309db98669781689568784e0fb1b7c (diff)
downloadsubsurface-b4b4e7872bb3078166a4b7519d26ca0828105ce4.tar.gz
build-system: add CMake SUBSURFACE_MOBILE_DESKTOP as new build type
Add -DSUBSURFACE_MOBILE_DESKTOP to CMake, allowing the C++ part to be different when compiling for a device or for the desktop. Signed-off-by: Jan Iversen <jan@casacondor.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 979ffc08d..3ee33346a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -179,6 +179,10 @@ elseif (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
endif()
list(APPEND QT_EXTRA_COMPONENTS QuickControls2)
add_definitions(-DSUBSURFACE_MOBILE)
+
+ # add definition to seperate mobile for devices and for desktop
+ add_definitions(-DSUBSURFACE_MOBILE_DESKTOP)
+
message(STATUS "Building Subsurface-mobile requires BT support")
set(BTSUPPORT ON)
endif()