summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-06 13:44:32 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-12-06 13:44:32 -0800
commitb928dff3ce5997d420c620690008115a85ffabba (patch)
tree345f4d88c9c87d2c726f30dbb1cceb5e330ab56e /CMakeLists.txt
parenteb0ccace773555c328bee98c78c43ed104d54481 (diff)
downloadsubsurface-b928dff3ce5997d420c620690008115a85ffabba.tar.gz
Only install QML Framework files for Subsurface-mobile
The workaround to building Subsurface-mobile on Mac messes with the ability to sign the bundle, so only do this when building Subsurface-mobile which we don't bundle, anyway. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 47dea0497..f09cf08b9 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -546,8 +546,10 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
string(REPLACE moc macdeployqt MACDEPLOYQT ${QT_MOC_EXECUTABLE})
install(CODE "execute_process(COMMAND ${MACDEPLOYQT} ${APP_BUNDLE_DIR} ${MACDEPLOY_ARGS})")
# and another hack to get the QML Components in the right place
- install(CODE "execute_process(COMMAND mkdir -p ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Frameworks/qml)")
- install(CODE "execute_process(COMMAND cp -a ${_qt5Core_install_prefix}/qml/QtQuick ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Frameworks/qml)")
+ if(SUBSURFACE_MOBILE)
+ install(CODE "execute_process(COMMAND mkdir -p ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Frameworks/qml)")
+ install(CODE "execute_process(COMMAND cp -a ${_qt5Core_install_prefix}/qml/QtQuick ${CMAKE_BINARY_DIR}/${APP_BUNDLE_DIR}/Contents/Frameworks/qml)")
+ endif()
install(CODE "message(STATUS \"two ERRORS here about libmysqlclient and libpq not found are harmless\")")
endif()