summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Lubomir I. Ivanov <neolit123@gmail.com>2015-09-22 14:45:40 +0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-09-22 07:18:53 -0700
commit0b0e203dbdb2eff253ca34472b7bc6c3033099c3 (patch)
tree44fc5ee85a8d8cd886658e646d27804ee48242a1 /CMakeLists.txt
parent7351ff62d7c345a075933f25b62967d3a97ae847 (diff)
downloadsubsurface-0b0e203dbdb2eff253ca34472b7bc6c3033099c3.tar.gz
Cmake: add LIBMARBLE_FROM_PKGCONFIG and some Marble related fixes
This patch adds the option to retrive Marble with pkg-config in a similar way to Grantlee, libgit2, etc. It reorganizes the "if(NO_MARBLE)" case to be the "else()" of if(NOT NO_MARBLE). Also, it adds the "-r" option to "rm" here: add_custom_target(link_marble_data ALL COMMAND rm -rf ./marbledata ... as otherwise it fails on Win32/Msys with "marbledata is a directory". Signed-off-by: Lubomir I. Ivanov <neolit123@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 17 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2b911f2bc..f2d299d91 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -10,6 +10,7 @@ set(CMAKE_AUTOUIC ON)
option(LIBGIT2_FROM_PKGCONFIG "use pkg-config to retrieve libgit2" OFF)
option(LIBDC_FROM_PKGCONFIG "use pkg-config to retrieve libdivecomputer" OFF)
option(LIBGRANTLEE_FROM_PKGCONFIG "use pkg-config to retrieve grantlee" OFF)
+option(LIBMARBLE_FROM_PKGCONFIG "use pkg-config to retrieve marble" OFF)
option(NO_MARBLE "disable the marble widget" OFF)
option(NO_TESTS "disable the tests" OFF)
option(NO_DOCS "disable the docs" OFF)
@@ -109,14 +110,24 @@ else()
include_directories(${LIBDIVECOMPUTER_INCLUDE_DIR})
endif()
-# optional marble
+# setup marble
+
if(NOT NO_MARBLE)
- find_package(Marble QUIET)
- if(MARBLE_FOUND)
- include_directories(${MARBLE_INCLUDE_DIR})
+ if(LIBMARBLE_FROM_PKGCONFIG)
+ pkg_config_library(MARBLE libmarble REQUIRED)
+ set(MARBLE_LIBRARIES "")
else()
- set(NO_MARBLE ON)
+ find_package(MARBLE QUIET)
+ if(MARBLE_FOUND)
+ include_directories(${MARBLE_INCLUDE_DIR})
+ else()
+ set(NO_MARBLE ON)
+ endif()
endif()
+else()
+ message(STATUS "building without marble widget support")
+ add_definitions(-DNO_MARBLE)
+ set(MARBLE_LIBRARIES "")
endif()
if(FTDISUPPORT)
@@ -129,12 +140,6 @@ if(FTDISUPPORT)
add_definitions(-DSERIAL_FTDI)
endif()
-if(NO_MARBLE)
- message(STATUS "building without marble widget support")
- add_definitions(-DNO_MARBLE)
- set(MARBLE_LIBRARIES "")
-endif()
-
if(ANDROID)
set(FBSUPPORT OFF)
set(NO_PRINTING ON)
@@ -187,7 +192,7 @@ get_filename_component(PARENTDIR ${${PROJECT_NAME}_SOURCE_DIR} PATH)
string(COMPARE EQUAL "${${PROJECT_NAME}_SOURCE_DIR}" "${PARENTDIR}" insourcesubdir)
if(NOT (insource OR insourcedir))
if(NOT NO_MARBLE)
- add_custom_target(link_marble_data ALL COMMAND rm -f marbledata && ln -s ${${PROJECT_NAME}_SOURCE_DIR}/marbledata ${${PROJECT_NAME}_BINARY_DIR}/marbledata)
+ add_custom_target(link_marble_data ALL COMMAND rm -rf ./marbledata && ln -s ${${PROJECT_NAME}_SOURCE_DIR}/marbledata ${${PROJECT_NAME}_BINARY_DIR}/marbledata)
endif()
endif()