summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2020-10-27 15:51:46 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-10-30 12:24:36 -0700
commit4b24730ee668d3940d40a7779d1965827f9448ce (patch)
tree1f94f6b78b1e448be96008bad858dbc50e8d2997 /CMakeLists.txt
parent31813af49a14d5e8989e3fa41b040d7541de35ac (diff)
downloadsubsurface-4b24730ee668d3940d40a7779d1965827f9448ce.tar.gz
add initial support for the Garmin Descent Mk2i
This brings in the needed libdivecomputer updates and builds Subsurface against libmtp in order to support downloading dive data via MTP (since the Mk2/Mk2i no longer provide a FAT filesystem via USB). In order for this to work you need to have libmtp installed on your system. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f27ba3c4b..d08af9382 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -156,6 +156,7 @@ if(NOT ANDROID)
pkg_config_library(BLUEZ bluez REQUIRED)
endif()
pkg_config_library(LIBUSB libusb-1.0 QUIET)
+ pkg_config_library(LIBMTP libmtp QUIET)
endif()
include_directories(.
@@ -284,7 +285,7 @@ if(NOT ANDROID)
endif()
#set up the subsurface_link_libraries variable
-set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${LIBUSB_LIBRARIES})
+set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${LIBUSB_LIBRARIES} ${LIBMTP_LIBRARIES})
qt5_add_resources(SUBSURFACE_RESOURCES subsurface.qrc map-widget/qml/map-widget.qrc)
# hack to build successfully on LGTM