summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2014-04-17 12:21:39 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2014-04-17 08:46:29 -0700
commit55d010bad839b503cbfa759498d18690f4a809ae (patch)
tree9139b3108d7eefa8a6a0b73cd109a93b02812e66 /CMakeLists.txt
parent95984628302bee02af3e82ac305b5e3bb4842533 (diff)
downloadsubsurface-55d010bad839b503cbfa759498d18690f4a809ae.tar.gz
Moved code around to make possible to compile the C part alone.
The C code should be compilable without the need to compile the Gui part, too. This is expecially good for unit testing as we can test all the algorithms without a window appearing out of nowhere. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 95872d1b4..ba318ca60 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -102,6 +102,8 @@ SET(SUBSURFACE_CORE_LIB_SRCS
linux.c
#gettextfrommoc should be added because we are using it on the c-code.
gettextfromc.cpp
+ #dirk ported some core functionality to c++.
+ qthelper.cpp
)
#the interface, in C++
@@ -192,7 +194,7 @@ ADD_DEPENDENCIES(subsurface_corelib version)
ENABLE_TESTING()
ADD_EXECUTABLE( TestUnitConversion tests/testunitconversion.cpp )
-TARGET_LINK_LIBRARIES( TestUnitConversion ${QT_LIBRARIES})
+TARGET_LINK_LIBRARIES( TestUnitConversion ${QT_LIBRARIES} ${SUBSURFACE_LINK_LIBRARIES} -lzip -ldivecomputer subsurface_corelib)
ADD_TEST( NAME TestUnitConversion COMMAND TestUnitConversion)
ADD_EXECUTABLE( TestProfile tests/testprofile.cpp )