summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Lubomir I. Ivanov <neolit123@gmail.com>2017-07-15 00:52:29 +0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-07-28 07:31:11 -0700
commit762a9d2ec2aecfa5e6caa7ea5f56ba8c49c3731a (patch)
tree9be9cfc1f0d61dd8efd1e5c8c59f407d0b039e06 /CMakeLists.txt
parent0fa7331240fcaf8675d5c1654c07de947502bdc2 (diff)
downloadsubsurface-762a9d2ec2aecfa5e6caa7ea5f56ba8c49c3731a.tar.gz
cmake: add the Quick, Location, QuickWidgets dependencies
Applies only to DesktopExecutable for now. Signed-off-by: Lubomir I. Ivanov <neolit123@gmail.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index beb86adbe..56cf02456 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -141,6 +141,12 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
else()
set(SUBSURFACE_TARGET subsurface)
endif()
+ list(APPEND QT_EXTRA_COMPONENTS Quick)
+ list(APPEND QT_EXTRA_COMPONENTS Location)
+ list(APPEND QT_EXTRA_COMPONENTS QuickWidgets)
+ list(APPEND QT_EXTRA_LIBRARIES Qt5::Quick)
+ list(APPEND QT_EXTRA_LIBRARIES Qt5::Location)
+ list(APPEND QT_EXTRA_LIBRARIES Qt5::QuickWidgets)
remove_definitions(-DSUBSURFACE_MOBILE)
elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")