summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-08 16:28:56 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-11-08 16:31:38 -0800
commit871f585f42fd59199d5c616fa93d6eb1037b445a (patch)
tree4a827ec11a30d9a57fe713cb2ba3a510682f7ffe /CMakeLists.txt
parent125217074e61ff25b901a05004208ccb21f121ce (diff)
downloadsubsurface-871f585f42fd59199d5c616fa93d6eb1037b445a.tar.gz
Make building plugins optional
This currently fails at least on my old Mac that I use to create binaries that work on 10.7 and newer. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4285a1f30..62e774e20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -23,6 +23,7 @@ option(SUBSURFACE_MOBILE "build the QtQuick version for mobile device" OFF)
option(FBSUPPORT "allow posting to Facebook" ON)
option(BTSUPPORT "enable support for QtBluetooth (requires Qt5.4 or newer)" ON)
option(FTDISUPPORT "enable support for libftdi based serial" OFF)
+option(DISABLE_PLUGINS "disable support for social media plugins" OFF)
add_definitions(-DSUBSURFACE_SOURCE="${CMAKE_SOURCE_DIR}")