summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@intel.com>2014-04-17 11:34:21 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2014-04-17 08:37:31 -0700
commit95984628302bee02af3e82ac305b5e3bb4842533 (patch)
tree56b104b93b6786e4314e88d4a9164d4eaae67178 /CMakeLists.txt
parentf14c14c383763c73de1a6ec681b017517235f2f6 (diff)
downloadsubsurface-95984628302bee02af3e82ac305b5e3bb4842533.tar.gz
Removed the globals 'userid' and 'save_userid_local' variables
This is a preferences setting, it should belong to the preferences structure. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@intel.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 69d9949b0..95872d1b4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -100,6 +100,8 @@ SET(SUBSURFACE_CORE_LIB_SRCS
uemis.c
uemis-downloader.c
linux.c
+ #gettextfrommoc should be added because we are using it on the c-code.
+ gettextfromc.cpp
)
#the interface, in C++
@@ -152,7 +154,6 @@ SET(SUBSURFACE_PROFILE_LIB_SRCS
#the main app.
SET(SUBSURFACE_APP
main.cpp
- gettextfromc.cpp
qt-gui.cpp
qthelper.cpp
)
@@ -193,3 +194,7 @@ ENABLE_TESTING()
ADD_EXECUTABLE( TestUnitConversion tests/testunitconversion.cpp )
TARGET_LINK_LIBRARIES( TestUnitConversion ${QT_LIBRARIES})
ADD_TEST( NAME TestUnitConversion COMMAND TestUnitConversion)
+
+ADD_EXECUTABLE( TestProfile tests/testprofile.cpp )
+TARGET_LINK_LIBRARIES( TestProfile ${QT_LIBRARIES} ${SUBSURFACE_LINK_LIBRARIES} -lzip -ldivecomputer subsurface_corelib)
+ADD_TEST( NAME TestProfile COMMAND TestProfile) \ No newline at end of file