summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-17 17:54:57 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-10-18 17:37:49 -0700
commitaf45a2a07261aaf04c0b87a5cec1f6a9f4a6e078 (patch)
treeef94928f8435f8c24744d925f38b848cddcb6e78 /CMakeLists.txt
parentff439396a538ade7ab470d4993912da93342e5d1 (diff)
downloadsubsurface-af45a2a07261aaf04c0b87a5cec1f6a9f4a6e078.tar.gz
Use hidapi on Mac
This allows us to support the Suunto EON Steel on Mac, assuming the matching libdivecomputer version from the Subsurface-branch. If that was compiled with the hdiapi lib then hopefully the build for Subsurface should find that library as well. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 287d1a83d..5e7c630a1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -285,6 +285,8 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(SUBSURFACE_TARGET Subsurface)
set(PLATFORM_SRC macos.c)
find_library(APP_SERVICES_LIBRARY ApplicationServices)
+ find_library(HID_LIB HidApi)
+ set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${HID_LIB})
set(EXTRA_LIBS ${APP_SERVICES_LIBRARY})
set(ICON_FILE ${CMAKE_SOURCE_DIR}/packaging/macosx/Subsurface.icns)
set(MACOSX_BUNDLE_INFO_STRING "Subsurface")