summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Jan Mulder <jlmulder@xs4all.nl>2018-01-09 16:30:03 +0100
committerGravatar Jan Mulder <jlmulder@xs4all.nl>2018-01-10 16:44:15 +0100
commitc8e9b934045a4627d142f44261a2846a9865ecfc (patch)
tree9addc8e5f8b30e605645a8c4b64444e6c46a4404 /CMakeLists.txt
parent8928e54dfce324185fcd22d1d32f6343c3a3f865 (diff)
downloadsubsurface-c8e9b934045a4627d142f44261a2846a9865ecfc.tar.gz
build system: split qt-models into parts
For a long time, I did not realize that a lot of qt-models are only used in the mobile app, or only used in the desktop application. This commit splits the qt-models in 3 parts. Used in both mobile and desktop, used in desktop only, used in mobile only. There is no other code change in here, other than cmake changes. To me, this gives at least developers more insight where code is actually used, and there is a small benefit in footpoint. Signed-off-by: Jan Mulder <jlmulder@xs4all.nl>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d4de6a6fc..d67879725 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -310,7 +310,7 @@ if(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
target_link_libraries(
${SUBSURFACE_TARGET}
subsurface_profile
- subsurface_models
+ subsurface_models_mobile
subsurface_corelib
${SUBSURFACE_LINK_LIBRARIES}
)
@@ -337,7 +337,7 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
${FACEBOOK_INTEGRATION}
subsurface_profile
subsurface_statistics
- subsurface_models
+ subsurface_models_desktop
subsurface_corelib
${SUBSURFACE_LINK_LIBRARIES}
)
@@ -345,7 +345,7 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
add_dependencies(subsurface_statistics subsurface_generated_ui)
add_dependencies(subsurface_interface subsurface_generated_ui)
add_dependencies(subsurface_profile subsurface_generated_ui)
- add_dependencies(subsurface_models subsurface_generated_ui)
+ add_dependencies(subsurface_models_desktop subsurface_generated_ui)
add_dependencies(subsurface_generated_ui version)
endif()