summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Rolf Eike Beer <eike@sf-mail.de>2019-03-03 22:57:10 +0100
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-05 13:27:54 -0800
commitf555fa787f54ca1fa23162fa0ade9addab387293 (patch)
treed671ca4b385314c587cebdeb78f0e1a42c15348e /CMakeLists.txt
parentb702e8e2257c259d5d4ab2ec1547057d525e03af (diff)
downloadsubsurface-f555fa787f54ca1fa23162fa0ade9addab387293.tar.gz
CMake: simplify writing qt.conf on Windows
Signed-off-by: Rolf Eike Beer <eike@sf-mail.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 3 insertions, 9 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 54ce2f11d..1bf03a09c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -364,15 +364,9 @@ add_dependencies(subsurface_corelib version)
# add platform specific actions
if(CMAKE_SYSTEM_NAME STREQUAL "Windows")
- add_custom_command(
- OUTPUT ${CMAKE_BINARY_DIR}/qt.conf
- COMMAND echo \"[Paths]\" > ${CMAKE_BINARY_DIR}/qt.conf \; echo \"Prefix=.\" >> ${CMAKE_BINARY_DIR}/qt.conf
- )
- add_custom_target(
- generate_qtconf
- DEPENDS ${CMAKE_BINARY_DIR}/qt.conf
- )
- add_dependencies(${SUBSURFACE_TARGET} generate_qtconf)
+ file(WRITE ${CMAKE_BINARY_DIR}/qt.conf "[Paths]
+Prefix=.
+")
endif()
# build an automated html exporter