summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Gehad elrobey <gehadelrobey@gmail.com>2015-05-29 21:31:15 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-04 10:07:41 -0700
commit0307ae98c21243a5ad491eecb984e58a5548104e (patch)
treede410f9eb18c12ca4649acc63c63e60539e4b430 /CMakeLists.txt
parent6de5cfb7a400897e6644668ffa9d0d4926b74590 (diff)
downloadsubsurface-0307ae98c21243a5ad491eecb984e58a5548104e.tar.gz
Printing: Change "NEW_PRINTING" to "NO_PRINTING"
If NO_PRINTING is not set, subsurface will require grantlee during building. As Grantlee will be a hard dependency for Subsurface, so no Grantlee means no printing. [Dirk Hohndel: switched default for NO_PRINTING to ON] Signed-off-by: Gehad elrobey <gehadelrobey@gmail.com> Signed-off-by: Lubomir I. Ivanov <neolit123@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt17
1 files changed, 13 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 34fc57659..1901ac599 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -13,6 +13,7 @@ option(LIBGRANTLEE_FROM_PKGCONFIG "use pkg-config to retrieve grantlee" OFF)
option(NO_MARBLE "disable the marble widget" OFF)
option(NO_TESTS "disable the tests" OFF)
option(NO_DOCS "disable the docs" OFF)
+option(NO_PRINTING "disable the printing support" ON)
option(USE_LIBGIT23_API "allow building with libgit2 master" OFF)
set(CMAKE_MODULE_PATH
@@ -94,7 +95,7 @@ endif()
# setup Grantlee
-if(NEW_PRINTING)
+if(NOT NO_PRINTING)
if(LIBGRANTLEE_FROM_PKGCONFIG)
pkg_config_library(GRANTLEE libgrantlee REQUIRED)
set(GRANTLEE_LIBRARIES "")
@@ -102,7 +103,16 @@ if(NEW_PRINTING)
find_package(Grantlee5)
set(GRANTLEE_LIBRARIES Grantlee5::Templates)
endif()
- add_definitions(-DNEW_PRINTING)
+ set(SUBSURFACE_PRINTING_SRCS
+ printer.cpp
+ templatelayout.cpp
+ )
+endif()
+
+if(NO_PRINTING)
+ message(STATUS "building without printing support")
+ add_definitions(-DNO_PRINTING)
+ set(GRANTLEE_LIBRARIES "")
endif()
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${GRANTLEE_LIBRARIES} -lusb-1.0)
@@ -260,8 +270,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
configuredivecomputer.cpp
configuredivecomputerthreads.cpp
divesitehelpers.cpp
- templatelayout.cpp
- printer.cpp
+ ${SUBSURFACE_PRINTING_SRCS}
${PLATFORM_SRC}
)
source_group("Subsurface Core" FILES ${SUBSURFACE_CORE_LIB_SRCS})