summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-16 06:04:34 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-16 06:04:34 -0700
commit0fa0eb2879bf72654a7febf8b977b0ba6f515658 (patch)
treec5bcdba3579ef86b342cc9671faa71a7ed5bb766 /CMakeLists.txt
parentc593dea119b4c5fa77a8b2cc129d048d7d56afa4 (diff)
downloadsubsurface-0fa0eb2879bf72654a7febf8b977b0ba6f515658.tar.gz
Code cleanup: implement window title update via signal
This seems quite convoluted to me but I can't seem to make a more straight forward implementation work. The idea is that core code should never directly call into the UI. So instead the core code (this is C code) calls a helper function. That helper function calls a member function of a class which in return emits a signal. The UI code connects to that signal and acts accordingly when it is received. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f5322b8e2..3222876ff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -274,6 +274,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
configuredivecomputer.cpp
configuredivecomputerthreads.cpp
divesitehelpers.cpp
+ windowtitleupdate.cpp
${SUBSURFACE_PRINTING_SRCS}
${PLATFORM_SRC}
)