summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-10 13:15:19 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-10 13:15:19 -0700
commit12b276d15c91bd4ca42cc5ed8a64242f957cacc7 (patch)
treec4e88ff7cc81683b3c6ab42f9dc59b7c1d4c65bf /CMakeLists.txt
parent6f997274f9112a9038a2e0837e709b9baadd531f (diff)
downloadsubsurface-12b276d15c91bd4ca42cc5ed8a64242f957cacc7.tar.gz
cmake: try to find the macdeployqt program
There is no variable for it, but we can abuse the variable that shows us where moc is located. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 008502871..d3bfa7376 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -398,7 +398,9 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
install(FILES ${TRANSLATIONS} DESTINATION ${RESOURCEDIR}/translations)
install(FILES ${QTTRANSLATIONS} DESTINATION ${RESOURCEDIR}/translations)
install(FILES ${CMAKE_SOURCE_DIR}/gpl-2.0.txt DESTINATION ${RESOURCEDIR})
- install(CODE "execute_process(COMMAND macdeployqt Subsurface.app)")
+ # this is a hack - but I don't know how else to find the macdeployqt program if it's not in the PATH
+ string(REPLACE moc macdeployqt MACDEPLOYQT ${QT_MOC_EXECUTABLE})
+ install(CODE "execute_process(COMMAND ${MACDEPLOYQT} Subsurface.app)")
ENDIF()
if(CMAKE_SYSTEM_NAME STREQUAL "Windows")