summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Claudiu Olteanu <olteanu.claudiu@ymail.com>2015-07-06 17:07:34 +0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-06 08:37:42 -0700
commit198cc419596dbd17f65124d0495e98fb7acf81c2 (patch)
treea0bb99131eb82932f6f0894c95b85310a25e6ac5 /CMakeLists.txt
parentdff4e5f33eee0ba112ddd2265410a5e858d6c98f (diff)
downloadsubsurface-198cc419596dbd17f65124d0495e98fb7acf81c2.tar.gz
Implement the custom Bluetooth serial communication and use it
Create a custom Bluetooth serial communication using the QTBluetooth API and use it when the Bluetooth download mode is enabled. First try to connect on RFCOMM channel 1 because this is the default RFCOMM channel of SPP service for most devices. If this doesn't work try again on RFCOMM channel number 5 because it could be a Petrel2 device. Add a fake open function for the custom implementation. This is used when the selected device is HW OSTC 2N and the Bluetooth mode is activated, then fake the open call of the serial device. Signed-off-by: Claudiu Olteanu <olteanu.claudiu@ymail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index eac98539f..77d202661 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -314,6 +314,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
windowtitleupdate.cpp
divelogexportlogic.cpp
qt-init.cpp
+ qtserialbluetooth.cpp
${PLATFORM_SRC}
)
source_group("Subsurface Core" FILES ${SUBSURFACE_CORE_LIB_SRCS})