summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-21 05:56:36 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-21 05:56:36 -0700
commit217c6462f5f32732afa18d3a5f074bd5f736afd0 (patch)
tree8a1d4907e9c0210ba5e631627e05f478a530a2eb /CMakeLists.txt
parentff906ba6993ded35d6ee6c708ab175373b7e19b5 (diff)
downloadsubsurface-217c6462f5f32732afa18d3a5f074bd5f736afd0.tar.gz
CMake support: turn building for mobile into an option
This way it can be easily turned on and off from ccmake. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 967fcab2d..1c52651a0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,7 @@ option(NO_TESTS "disable the tests" OFF)
option(NO_DOCS "disable the docs" OFF)
option(NO_PRINTING "disable the printing support" ON)
option(USE_LIBGIT23_API "allow building with libgit2 master" OFF)
+option(SUBSURFACE_MOBILE "build the QtQuick version for mobile device" OFF)
set(CMAKE_MODULE_PATH
${CMAKE_MODULE_PATH}