summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-16 06:58:22 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-16 14:09:21 -0700
commit226e9a7e85ef1cf148daa61a54039ebfa060f4cb (patch)
treeffbba2fae0944c919d18581d133d6e58591222b5 /CMakeLists.txt
parent0692e2403600090cf92efed375136c3d256f71ac (diff)
downloadsubsurface-226e9a7e85ef1cf148daa61a54039ebfa060f4cb.tar.gz
Implement a standalone HTML exporter
This is mostly a proof of concept right now; it shows that it is possible to create a headless server application that exports a git repository based data file as html. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 16e0c6430..d1b59c849 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -444,6 +444,10 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Windows")
add_dependencies(${SUBSURFACE_TARGET} generate_qtconf)
endif()
+# build an automated html exporter
+add_executable(export-html EXCLUDE_FROM_ALL export-html.cpp qt-init.cpp qthelper.cpp ${SUBSURFACE_RESOURCES})
+target_link_libraries(export-html subsurface_corelib ${SUBSURFACE_LINK_LIBRARIES})
+
# QTest based tests
macro(TEST NAME FILE)
add_executable(${NAME} EXCLUDE_FROM_ALL tests/${FILE} ${SUBSURFACE_RESOURCES})