summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2020-11-24 20:15:45 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-12-17 09:17:54 -0800
commit24bb4d76772e4142eca3ba01ed1902d9b56b1f10 (patch)
tree84fbbf63fa352c6246741c2bdff3ae2317db1c2b /CMakeLists.txt
parenta883fce6129d053193917f2346e17f84dda3af13 (diff)
downloadsubsurface-24bb4d76772e4142eca3ba01ed1902d9b56b1f10.tar.gz
mobile/kirigami: install our own copy of ECM
Instead of relying on this being available as a system resource, treat it the same way as we treat Kirigami and the Breeze icons. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9b0ae88b4..48cb26b16 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -331,7 +331,7 @@ if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "MobileExecutable")
# set up Kirigami using KDE ECM
# that's available as kde-extra-cmake-modules on Homebrew, on all Linux flavors
# Android and iOS are built via qmake, Windows build of Subsurface-mobile isn't supported
- find_package(ECM REQUIRED CONFIG)
+ find_package(ECM REQUIRED CONFIG PATHS ${CMAKE_CURRENT_SOURCE_DIR}/mobile-widgets/3rdparty/ECM)
set(CMAKE_MODULE_PATH ${CMAKE_CURRENT_SOURCE_DIR}/cmake/ ${CMAKE_MODULE_PATH} ${ECM_MODULE_PATH})
set(BREEZEICONS_DIR mobile-widgets/3rdparty/breeze-icons/)