summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-03-26 12:52:48 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-03-26 12:52:48 -0700
commit3378894291347387d3bc0636a857d255b0c1953d (patch)
tree39f906501aca9c9e1bf2e2f5af9f23632ae8d773 /CMakeLists.txt
parentc41b1dc6888fea68d38a61be0a5b8058a369f52b (diff)
downloadsubsurface-3378894291347387d3bc0636a857d255b0c1953d.tar.gz
cmake: add CoreServices framework for Mac
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 639945d2d..3cde8e3f2 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -125,6 +125,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
ENDIF()
IF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
SET(PLATFORM_SRC macos.c)
+ set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -framework CoreServices)
ENDIF()
IF(CMAKE_SYSTEM_NAME STREQUAL "Windows")
SET(PLATFORM_SRC windows.c)