summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@gmail.com>2015-04-22 18:45:28 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-26 12:17:17 -0700
commit34c88f9a15cc2421841b67fbdf0e67c392968b41 (patch)
tree555c878c27044dc06226a84ee111ba4e6dde67e3 /CMakeLists.txt
parent6ace243a2a528ddb9443ccb6c4abc7228a558fc2 (diff)
downloadsubsurface-34c88f9a15cc2421841b67fbdf0e67c392968b41.tar.gz
CMake needs hints that this will be a win32 or a mac bundle.
MACOSX_BUNDLE and WIN32 give hints to cmake for different install behaviors. for instance, trying to copy frameworks and other stuff to the correct places. Signed-off-by: Tomaz Canabrava <tomaz.canabrava@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e4c5cc4a9..e4defa1cb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -328,7 +328,7 @@ endif()
# create the executables
-add_executable(${SUBSURFACE_TARGET} ${SUBSURFACE_PKG} ${SUBSURFACE_APP} ${SUBSURFACE_RESOURCES})
+add_executable(${SUBSURFACE_TARGET} MACOSX_BUNDLE WIN32 ${SUBSURFACE_PKG} ${SUBSURFACE_APP} ${SUBSURFACE_RESOURCES})
target_link_libraries(
${SUBSURFACE_TARGET}
subsurface_generated_ui