summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-03 12:34:23 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-03 12:34:23 -0700
commit3dac769c333ffce6fa10f0bc7985a7a19953af24 (patch)
treec801742bbaf983cc76fd4ef7f94078b703e8cd1c /CMakeLists.txt
parent6a466d0cfb61aa6a7178afcb4cbb97fda00f8423 (diff)
downloadsubsurface-3dac769c333ffce6fa10f0bc7985a7a19953af24.tar.gz
cmake: correctly link against CoreServices
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a45ec0634..997848cf4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -157,7 +157,8 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
ENDIF()
IF(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
SET(PLATFORM_SRC macos.c)
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -framework CoreServices)
+ FIND_LIBRARY(APP_SERVICES_LIBRARY ApplicationServices )
+ SET(EXTRA_LIBS ${APP_SERVICES_LIBRARY})
if(NOT DEFINED LRELEASE)
set(LRELEASE lrelease)
endif()