summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-16 20:17:07 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-03-16 20:24:07 -0700
commit4dd6b826348ca5cdaaa3deba881bc4fe02595589 (patch)
tree378a5f37018533b3f461b13cca4c6c63e1081431 /CMakeLists.txt
parent2b5d818d354e6602a7cdd7f8203c6f6baa356cf9 (diff)
downloadsubsurface-4dd6b826348ca5cdaaa3deba881bc4fe02595589.tar.gz
build-system: explicitly add libgit2 dependencies for LGTM
For some reason on LGTM these two libraries aren't automatically added to the link line for Subsurface. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e57c1118a..2c54dc473 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -276,6 +276,11 @@ endif()
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${LIBUSB_LIBRARIES})
qt5_add_resources(SUBSURFACE_RESOURCES subsurface.qrc map-widget/qml/map-widget.qrc)
+# hack to build successfully on LGTM
+if(DEFINED ENV{LGTM_SRC})
+ set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lgssapi_krb5 -lhttp_parser)
+endif()
+
# include translations
add_subdirectory(translations)
add_subdirectory(core)