summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-19 20:33:54 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-19 20:33:54 -0700
commit56d701dfff72bb4e59f23432c5b7d9c356132412 (patch)
tree6550cb8ef679944f40fd3f93f1f0046ac11523e0 /CMakeLists.txt
parent56b82e0ecf58dd1f2b7585425dbdebbbbe5668a4 (diff)
parentb039e1db8a4d8d745a455dd70b4434acffb5c1c4 (diff)
downloadsubsurface-56d701dfff72bb4e59f23432c5b7d9c356132412.tar.gz
Merge branch 'custom-print' of https://github.com/neolit123/subsurface
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 5 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d1b59c849..e31822e0d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -99,7 +99,11 @@ endif()
# setup Grantlee
-if(NOT NO_PRINTING)
+if(NO_PRINTING)
+ message(STATUS "building without printing support")
+ add_definitions(-DNO_PRINTING)
+ set(GRANTLEE_LIBRARIES "")
+else()
if(LIBGRANTLEE_FROM_PKGCONFIG)
pkg_config_library(GRANTLEE libgrantlee REQUIRED)
set(GRANTLEE_LIBRARIES "")
@@ -113,12 +117,6 @@ if(NOT NO_PRINTING)
)
endif()
-if(NO_PRINTING)
- message(STATUS "building without printing support")
- add_definitions(-DNO_PRINTING)
- set(GRANTLEE_LIBRARIES "")
-endif()
-
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} ${LIBDIVECOMPUTER_LIBRARIES} ${LIBGIT2_LIBRARIES} ${GRANTLEE_LIBRARIES} -lusb-1.0)
# handle out of tree build correctly