summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-16 07:24:25 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-16 07:25:49 -0700
commit6662f2864fe58bec01a9f4480d39c8bb710c564b (patch)
treedf47364a7e378a15e59d1c98a5347b7d7de8a288 /CMakeLists.txt
parent5ecf4650b477d9184f91b4f0e1351abc69775cc1 (diff)
downloadsubsurface-6662f2864fe58bec01a9f4480d39c8bb710c564b.tar.gz
cmake: fix bug when using system libgit2
Simple omission in commit 7596db28b5ad ("cmake: allow looking for optional libraries"). Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8d4a22c1..93b0bdf42 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -31,7 +31,7 @@ pkg_config_library(LIBUSB libusb-1.0 QUIET)
# more libraries with special handling in case we build them ourselves
if(NOT ${PREFER_GIT_FROMSOURCE})
- pkg_config_library(LIBGIT2 libgit2)
+ pkg_config_library(LIBGIT2 libgit2 REQUIRED)
ELSE()
FIND_PACKAGE(LIBGIT2 REQUIRED)
INCLUDE_DIRECTORIES(${LIBGIT2_INCLUDE_DIR})