summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-16 06:34:40 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-16 14:04:41 -0700
commit6a0e1cd9f6da893a7da4fa82de6ef47bb645f617 (patch)
treed38e7f4c7b4ff8c3758c9300e3bdfcaf55695a66 /CMakeLists.txt
parenta2c546152ebfd0e01dd7021433aa04b94150bf4a (diff)
downloadsubsurface-6a0e1cd9f6da893a7da4fa82de6ef47bb645f617.tar.gz
HTML export: separate UI and logic code
In order to be able to initiate an HTML export from the core library we need to separate the actual logic from the UI. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 22eb08937..8ac86f726 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -276,6 +276,7 @@ set(SUBSURFACE_CORE_LIB_SRCS
divesitehelpers.cpp
checkcloudconnection.cpp
windowtitleupdate.cpp
+ divelogexportlogic.cpp
${SUBSURFACE_PRINTING_SRCS}
${PLATFORM_SRC}
)