summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-01-16 15:56:56 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-01-16 17:00:55 -0800
commit73641c4e73d8634eebe8fe00b96ba039da883b27 (patch)
treeac75ab4d3e4cef086514a0a8955020a9c079e82d /CMakeLists.txt
parentc749498bebd84e9454abb289f819cdfffc346055 (diff)
downloadsubsurface-73641c4e73d8634eebe8fe00b96ba039da883b27.tar.gz
build.sh: if new enough libgit2 is installed, use it
Right now this is only designed for Linux where current distros all should have a new enough libgit2 (and our instructions tell people to install this with system tools, so we should also use it). Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 09936c834..811480149 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -22,6 +22,7 @@ option(LIBMARBLE_FROM_PKGCONFIG "use pkg-config to retrieve marble" OFF)
#Library Handling
option(FORCE_LIBSSH "force linking with libssh to workaround libgit2 bug" ON)
+option(LIBGIT2_DYNAMIC "search for libgit2.so before libgit2.a" OFF)
#Options regarding disabling parts of subsurface.
option(NO_MARBLE "disable the marble widget" OFF)