summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-09 16:55:27 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-09 16:55:27 -0700
commit9d0f2a6571f541862fd8204c067ea2f5ed2c4091 (patch)
treec52a13e30057edf7ad67ebcde78c07d37b98d0b7 /CMakeLists.txt
parente60e133e76736c0f44a7fe0374ec44044db8cc45 (diff)
downloadsubsurface-9d0f2a6571f541862fd8204c067ea2f5ed2c4091.tar.gz
Fix Ubuntu build
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3ada22a35..c5e039185 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,7 +62,7 @@ else()
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DUSE_LIBGIT23_API")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DUSE_LIBGIT23_API")
find_package(libssh2 QUIET)
- if(!LIBSSH2_FOUND)
+ if(!LIBSSH2_FOUND OR "${LIBSSH2_FOUND}" STREQUAL "")
pkg_config_library(LIBSSH2 libssh2 REQUIRED)
endif()
set(LIBGIT2_LIBRARIES ${LIBGIT2_LIBRARIES} ${LIBSSH2_LIBRARIES})