summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Tomaz Canabrava <tomaz.canabrava@gmail.com>2015-06-28 13:57:52 -0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-29 06:43:44 -0700
commitab6e2cc9b4b93aa9cc84d91fa2c9c76319e4f77c (patch)
tree38a2907bc743cbba57d4316268c8553eeed785a7 /CMakeLists.txt
parent65babff6bcc43f3a28e107caee12024209c31010 (diff)
downloadsubsurface-ab6e2cc9b4b93aa9cc84d91fa2c9c76319e4f77c.tar.gz
Fix build with libssh from git
Signed-off-by: Tomaz Canabrava <tomaz.canabrava@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 943de13ef..f9ab5e47c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -63,6 +63,9 @@ else()
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DUSE_LIBGIT23_API")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DUSE_LIBGIT23_API")
find_package(libssh2 QUIET)
+ if (${LIBSSH2_VERSION} STRGREATER "1.6.0")
+ set(LIBSSH2_LIBRARIES Libssh2::libssh2)
+ endif()
if(!LIBSSH2_FOUND OR "${LIBSSH2_FOUND}" STREQUAL "")
pkg_config_library(LIBSSH2 libssh2 REQUIRED)
endif()