summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Anton Lundin <glance@acc.umu.se>2015-07-01 17:08:35 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-01 09:00:13 -0700
commitc3f6fcb0bfd4e66f77dbc9daee442fbd5dc7e003 (patch)
tree3f30911b58790d8d4ff83198693fffaa835e04e9 /CMakeLists.txt
parenteda0190e2ad0b4e7a813d559f022d9f0b8f41831 (diff)
downloadsubsurface-c3f6fcb0bfd4e66f77dbc9daee442fbd5dc7e003.tar.gz
Fix NO_PRINTING when printing is disabled in Qt
Qt for android doesn't have any printing support, so this fixes NO_PRINTING so we can build against a Qt without any printing support at all. Signed-off-by: Anton Lundin <glance@acc.umu.se> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3fe2d8702..f92afeae5 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -120,6 +120,8 @@ else()
printer.cpp
templatelayout.cpp
)
+ set(PRINTING_PKG PrintSupport)
+ set(PRINTING_LIB Qt5::PrintSupport)
endif()
if(NO_USERMANUAL)
@@ -153,8 +155,8 @@ if(SUBSURFACE_MOBILE)
set(QT_QUICK_PKG Quick)
set(QT_QUICK_LIB Qt5::Quick)
endif()
-find_package(Qt5 REQUIRED COMPONENTS Core Concurrent Widgets Network ${WEBKIT_PKG} PrintSupport Svg Test LinguistTools ${QT_QUICK_PKG})
-set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} Qt5::PrintSupport Qt5::Svg ${QT_QUICK_LIB})
+find_package(Qt5 REQUIRED COMPONENTS Core Concurrent Widgets Network ${WEBKIT_PKG} ${PRINTING_PKG} Svg Test LinguistTools ${QT_QUICK_PKG})
+set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} ${PRINTING_LIB} Qt5::Svg ${QT_QUICK_PKG})
set(QT_TEST_LIBRARIES ${QT_LIBRARIES} Qt5::Test)
# Generate the ssrf-config.h every 'make'