summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-24 07:18:11 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-24 07:18:11 -0700
commitc97e136435e61e72800baa6da37f82c5240ac642 (patch)
tree9ef9a7bd5247b0615457132f0e7b09a6861518d6 /CMakeLists.txt
parent79bb61dba186f8439d30dcf98b7f9dc8e9c2b687 (diff)
downloadsubsurface-c97e136435e61e72800baa6da37f82c5240ac642.tar.gz
cmake: include the git SHA in the Windows installer name
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 06fd5099b..bc7250136 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -127,7 +127,7 @@ file(WRITE ${CMAKE_BINARY_DIR}/version.cmake "
if(CMAKE_SYSTEM_NAME STREQUAL \"Windows\")
execute_process(
COMMAND cat ${CMAKE_SOURCE_DIR}/packaging/windows/subsurface.nsi.in
- COMMAND sed -e \"s/VERSIONTOKEN/\${VERSION_STRING}/\"
+ COMMAND sed -e \"s/VERSIONTOKEN/\${GIT_VERSION_STRING}/\"
COMMAND sed -e \"s/PRODVTOKEN/\${CANONICAL_VERSION_STRING}/\"
OUTPUT_FILE ${CMAKE_BINARY_DIR}/staging/subsurface.nsi
)