summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-09 16:37:43 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-09 16:37:43 -0700
commitcbda93ce11f14f853f6b618a347391da45dd5da1 (patch)
tree53dc6cff9f5f3f7ab9252a0c6d74bdb52ccd5e46 /CMakeLists.txt
parent9217a03ef3f6bd0e96b6ea4b5ae366c5b3f02379 (diff)
downloadsubsurface-cbda93ce11f14f853f6b618a347391da45dd5da1.tar.gz
Add different icon for mobile app
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6e938a3e0..f4b328f02 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -719,13 +719,14 @@ endif()
if(ANDROID)
# Android template directory
- set(ANDROID_PACKAGE_SOURCE_DIR, ${CMAKE_BINARY_DIR}/android)
include(${QT_ANDROID_CMAKE})
if(SUBSURFACE_MOBILE)
+ set(ANDROID_PACKAGE_SOURCE_DIR, ${CMAKE_BINARY_DIR}/android-mobile)
add_qt_android_apk(subsurface-mobile.apk subsurface-mobile
PACKAGE_SOURCES ${CMAKE_CURRENT_LIST_DIR}/android
)
else()
+ set(ANDROID_PACKAGE_SOURCE_DIR, ${CMAKE_BINARY_DIR}/android)
add_qt_android_apk(subsurface.apk ${SUBSURFACE_TARGET}
PACKAGE_SOURCES ${CMAKE_CURRENT_LIST_DIR}/android
)