summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-06 12:11:07 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-06 12:11:07 -0700
commitcf047466b5d297d80644194cc76f0a30ad2bac91 (patch)
tree98e8ceebee3ac6f0a6e36935dad054453fcd4b11 /CMakeLists.txt
parent6ebeba3c7c142994051061c495850827e51b552f (diff)
downloadsubsurface-cf047466b5d297d80644194cc76f0a30ad2bac91.tar.gz
Cmake: make Facebook support an actual option
This way we can selectively turn off Facebook support. And turning off both Facebook support and support for the user manual allows us to not rely on QWebKit which once again allows debugging Subsurface with valgrind on Arch Linux. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 2 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 77d202661..b4eed8bed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,7 @@ option(NO_PRINTING "disable the printing support" ON)
option(NO_USERMANUAL "don't include a viewer for the user manual" OFF)
option(USE_LIBGIT23_API "allow building with libgit2 master" OFF)
option(SUBSURFACE_MOBILE "build the QtQuick version for mobile device" OFF)
+option(FBSUPPORT "allow posting to Facebook" ON)
set(CMAKE_MODULE_PATH
${CMAKE_MODULE_PATH}
@@ -160,6 +161,7 @@ endif()
if(CMAKE_SYSTEM_NAME STREQUAL "Android")
set(ANDROID_PKG AndroidExtras)
set(ANDROID_LIB Qt5::AndroidExtras)
+ set(FBSUPPORT OFF)
endif()
find_package(Qt5 REQUIRED COMPONENTS Core Concurrent Widgets Network ${WEBKIT_PKG} ${PRINTING_PKG} Svg Test LinguistTools ${QT_QUICK_PKG} ${ANDROID_PKG} Bluetooth)
set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} ${PRINTING_LIB} Qt5::Svg ${QT_QUICK_LIB} ${ANDROID_LIB} Qt5::Bluetooth)
@@ -223,7 +225,6 @@ add_custom_target(
# set up the different target platforms
set(PLATFORM_SRC unknown_platform.c)
if(CMAKE_SYSTEM_NAME STREQUAL "Linux")
- set(FBSUPPORT 1)
set(SUBSURFACE_TARGET subsurface)
set(PLATFORM_SRC linux.c)
# in some builds we appear to be missing libz for some strange reason...
@@ -236,7 +237,6 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Android")
set(SUBSURFACE_TARGET subsurface)
endif()
if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- set(FBSUPPORT 1)
set(SUBSURFACE_TARGET Subsurface)
set(PLATFORM_SRC macos.c)
find_library(APP_SERVICES_LIBRARY ApplicationServices)
@@ -254,7 +254,6 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
set(SUBSURFACE_PKG MACOSX_BUNDLE ${ICON_FILE})
endif()
if(CMAKE_SYSTEM_NAME STREQUAL "Windows")
- set(FBSUPPORT 1)
set(SUBSURFACE_TARGET subsurface)
set(PLATFORM_SRC windows.c)
set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lwsock32)