summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-29 12:33:33 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-29 12:33:33 -0700
commitda7fb2eff4c2b24dd0fde4fe0de618fc5832194e (patch)
treea3a809760ca87387aebeb4161a06661cda20af93 /CMakeLists.txt
parent57bad198cbaaae20a1357377ecfddd72bf697882 (diff)
downloadsubsurface-da7fb2eff4c2b24dd0fde4fe0de618fc5832194e.tar.gz
Cmake: another attempt to make things work with libssh2
This seems to work on all the systems I was able to test it on. Famous last words. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f9ab5e47c..7784fd7ef 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,8 +62,8 @@ else()
if(USE_LIBGIT23_API)
set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DUSE_LIBGIT23_API")
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DUSE_LIBGIT23_API")
- find_package(libssh2 QUIET)
- if (${LIBSSH2_VERSION} STRGREATER "1.6.0")
+ find_package(Libssh2 QUIET CONFIG)
+ if (${LIBSSH2_VERSION} STRGREATER "1.6.1")
set(LIBSSH2_LIBRARIES Libssh2::libssh2)
endif()
if(!LIBSSH2_FOUND OR "${LIBSSH2_FOUND}" STREQUAL "")