summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Grace Karanja <gracie.karanja89@gmail.com>2015-07-02 10:15:38 +0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-05 16:01:54 -0700
commitdb3a9abac920b0dc9fbaed7d80951d3ec0a83c34 (patch)
tree9ff0eeea0c4e7416ef329c3d4ac3a883385e7366 /CMakeLists.txt
parente864c365c77dd385f038c432446573c402dee819 (diff)
downloadsubsurface-db3a9abac920b0dc9fbaed7d80951d3ec0a83c34.tar.gz
Correctly include QtQuick when building for mobile
The changed introduced in d880040d breaks mobile builds by not correctly linking with QtQuick. This change fixes that by fixing the incorrect line in CMakeLists.txt so that the correct QtQuick headers will be found. Signed-off-by: Grace Karanja <gracie.karanja89@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index fbfbfa45a..179c5677f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -160,7 +160,7 @@ if(CMAKE_SYSTEM_NAME STREQUAL "Android")
set(ANDROID_LIB Qt5::AndroidExtras)
endif()
find_package(Qt5 REQUIRED COMPONENTS Core Concurrent Widgets Network ${WEBKIT_PKG} ${PRINTING_PKG} Svg Test LinguistTools ${QT_QUICK_PKG} ${ANDROID_PKG})
-set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} ${PRINTING_LIB} Qt5::Svg ${QT_QUICK_PKG} ${ANDROID_LIB})
+set(QT_LIBRARIES Qt5::Core Qt5::Concurrent Qt5::Widgets Qt5::Network ${WEBKIT_LIB} ${PRINTING_LIB} Qt5::Svg ${QT_QUICK_LIB} ${ANDROID_LIB})
set(QT_TEST_LIBRARIES ${QT_LIBRARIES} Qt5::Test)
# Generate the ssrf-config.h every 'make'