summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Grace Karanja <gracie.karanja89@gmail.com>2015-06-04 13:31:03 +0300
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-20 14:19:56 -0700
commite0a25289db50390e92723d6e2298d10f2270ca8a (patch)
tree90ea0ea7961d55e62386ede3ef360acb5d3e12a7 /CMakeLists.txt
parent59be048549cfe620d0ddfcd891e04ec6e2fad3f7 (diff)
downloadsubsurface-e0a25289db50390e92723d6e2298d10f2270ca8a.tar.gz
Add QMLManager to the cmake
Build the QMLManager class when compiling for mobile. Signed-off-by: Grace Karanja <gracie.karanja89@gmail.com> Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b602a4793..96fa7edff 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -423,9 +423,10 @@ endif()
# create the executables
if(SUBSURFACE_MOBILE)
+ set(MOBILE_SRC qt-mobile/qmlmanager.cpp)
add_definitions(-DSUBSURFACE_MOBILE)
qt5_add_resources(MOBILE_RESOURCES qt-mobile/mobile-resources.qrc)
- add_executable(subsurface-mobile ${SUBSURFACE_PKG} ${SUBSURFACE_APP} ${SUBSURFACE_RESOURCES} ${MOBILE_RESOURCES})
+ add_executable(subsurface-mobile ${MOBILE_SRC} ${SUBSURFACE_PKG} ${SUBSURFACE_APP} ${SUBSURFACE_RESOURCES} ${MOBILE_RESOURCES})
target_link_libraries(
subsurface-mobile
subsurface_generated_ui