summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-20 06:46:49 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-06-20 06:46:49 -0700
commitf0706207df377e876b2f0d3466941564967b7e35 (patch)
tree71f5aea0c4f4bcea374425c5cc4d74d5eec844e4 /CMakeLists.txt
parentde35c886837016c80fc65043d8a2f0b373efec5b (diff)
downloadsubsurface-f0706207df377e876b2f0d3466941564967b7e35.tar.gz
Cmake support: remove Documentation/images in build dir
In earlier versions we didn't simply create a link but actually copied the directory and its contents. So for this to work smoothly for people who have built earlier versions of Subsurface with cmake we need to no just remove the link but be willing to recursively remove that directory. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e562bd872..cb5082d49 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -490,7 +490,7 @@ if(NOT insource)
documentationLink ALL
COMMAND
mkdir -p ${CMAKE_BINARY_DIR}/Documentation/ &&
- rm -f ${CMAKE_BINARY_DIR}/Documentation/images &&
+ rm -rf ${CMAKE_BINARY_DIR}/Documentation/images &&
ln -s ${CMAKE_SOURCE_DIR}/Documentation/images ${CMAKE_BINARY_DIR}/Documentation/images
)
endif()