summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-13 14:13:32 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-07-13 15:21:16 -0700
commitf35a2713659a6114062a2403d428ec7f33744040 (patch)
tree7a5ede91ca54eeb477a5cad72c3dc6f917e889b1 /CMakeLists.txt
parentb554ed5ed61c3c56d596d8f4f54c29ee91d434e7 (diff)
downloadsubsurface-f35a2713659a6114062a2403d428ec7f33744040.tar.gz
Android build: statically link against libssl and libcrypto
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7ec08ae1..5b94d13bd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -59,6 +59,12 @@ if(LIBGIT2_FROM_PKGCONFIG)
pkg_config_library(LIBSSH2 libssh2 REQUIRED)
set(LIBGIT2_LIBRARIES ${LIBGIT2_LIBRARIES} ${LIBSSH2_LIBRARIES})
endif()
+ if(ANDROID)
+ # for Android we need to force a static link against ssl and crypto
+ # this is a bit hacky, but it seems to work
+ set(LIBGIT2_LIBRARIES ${LIBGIT2_LIBRARIES} ${LIBGIT2_LIBRARY_DIRS}/libssl.a ${LIBGIT2_LIBRARY_DIRS}/libcrypto.a)
+ endif()
+
endif()
else()
find_package(LIBGIT2 REQUIRED)