summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-04 16:21:32 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2015-04-04 16:21:32 -0700
commit072422075e9d4f50b297091efe1ed4c4d56c279d (patch)
tree1fcd103f4d718e3eebd8d510ce56ed45218aecd9 /CMakeLists.txt
parentb79c01ab7ca96a6c3d684405aa0d9f7b7405903e (diff)
downloadsubsurface-072422075e9d4f50b297091efe1ed4c4d56c279d.tar.gz
cmake: try to pick a useful default for the location of Qt translations
Not sure if this will work for most installations - it does work for mine. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f87234a19..ee0eccc1e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -436,6 +436,9 @@ foreach(TRANSLATION ${TRANSLATION_SRC})
set(TRANSLATIONS ${TRANSLATIONS} ${CMAKE_BINARY_DIR}/${TRANSLATION_QM})
endforeach()
+if(QT_TRANSLATION_DIR STREQUAL "")
+ set(QT_TRANSLATION_DIR ${Qt5Core_DIR}/../../../translations)
+endif()
set(QTTRANSLATIONS "")
foreach(QTTRANSLATION ${QTTRANSLATIONS_BASE})
if(NOT ${QTTRANSLATION} STREQUAL "")