summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-10-20 17:22:57 -0400
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-10-20 17:23:00 -0400
commit12dac214aa96eb755f975f3eae464e4abd80ad76 (patch)
treed10b96af72be3d6e473f0dcd0d6c4744d5690441 /CMakeLists.txt
parent3f5396efddb8ec0b0ed2d289efb93e91d110a9a6 (diff)
downloadsubsurface-12dac214aa96eb755f975f3eae464e4abd80ad76.tar.gz
cmake: deal with occasional build order issue
I only ran into this a couple of times and can't figure out why it picked the order in which it tried to build things - but hard coding the dependency seems to have fixed it (then again, since I didn't always run into this, I'm not sure). Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 926167bd5..735185cb3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -302,6 +302,7 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
if(FBSUPPORT)
set(FACEBOOK_INTEGRATION facebook_integration)
+ add_dependencies(facebook_integration subsurface_generated_ui)
endif()
target_link_libraries(
${SUBSURFACE_TARGET}
@@ -314,6 +315,7 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "DesktopExecutable")
subsurface_corelib
${SUBSURFACE_LINK_LIBRARIES}
)
+ add_dependencies(subsurface_desktop_preferences subsurface_generated_ui)
add_dependencies(subsurface_statistics subsurface_generated_ui)
add_dependencies(subsurface_interface subsurface_generated_ui)
add_dependencies(subsurface_profile subsurface_generated_ui)