summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2017-04-01 09:35:26 +0200
committerGravatar Dirk Hohndel <dirk@hohndel.org>2017-04-01 09:37:15 +0200
commit3a003f4c1052a29219057a5cf513d6f53325d755 (patch)
tree3d964248972a202bc78505936a614e440831eeb4 /CMakeLists.txt
parent4113bab17b6b9f2415fffe0d10b2926dd8f7788b (diff)
downloadsubsurface-3a003f4c1052a29219057a5cf513d6f53325d755.tar.gz
QML UI: we now depend on QuckControls2
Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dfa6123a0..cca2c0a38 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -157,7 +157,9 @@ elseif(${SUBSURFACE_TARGET_EXECUTABLE} MATCHES "MobileExecutable")
set(SUBSURFACE_TARGET subsurface-mobile)
endif()
list(APPEND QT_EXTRA_COMPONENTS Quick)
+ list(APPEND QT_EXTRA_COMPONENTS QuickControls2)
list(APPEND QT_EXTRA_LIBRARIES Qt5::Quick)
+ list(APPEND QT_EXTRA_LIBRARIES Qt5::QuickControls2)
add_definitions(-DSUBSURFACE_MOBILE)
endif()