summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2020-10-23 20:48:15 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2020-10-23 20:48:15 -0700
commit4801dcecf3d43d6a02b88f7f22ca16a4ad3332ca (patch)
tree9b7e2b176a3f185373b21e8560f96693301232a3 /CMakeLists.txt
parentad59f100ae0421bc46290bd6f92d5431e319650f (diff)
downloadsubsurface-4801dcecf3d43d6a02b88f7f22ca16a4ad3332ca.tar.gz
cleanup: remove outdated explicit libssh2 link
We used to need this when building our own libgit2 on older distibutions. This shouldn't be needed anymore at all. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e3e6ad780..dbb2995dd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -211,8 +211,7 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Linux")
# this is only needed on Ubuntu
# but shouldn't hurt on other Linux versions
# in some builds we appear to be missing libz for some strange reason...
- # Add ssh2 at the end for openSUSE builds (for recent cmake?)
- set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lssh2 -lz -lpthread)
+ set(SUBSURFACE_LINK_LIBRARIES ${SUBSURFACE_LINK_LIBRARIES} -lz -lpthread)
# Test for ARM processor (Raspberry Pi) and add libGLESv2 if found
if (CMAKE_SYSTEM_PROCESSOR STREQUAL "armv7l" OR CMAKE_SYSTEM_PROCESSOR STREQUAL "armv6l")