summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2018-11-14 00:20:18 -0800
committerGravatar Dirk Hohndel <dirk@hohndel.org>2018-11-14 00:20:18 -0800
commit5963a15bbd8479a1a3eafcb5fc8bf9a98ccc2769 (patch)
treedf4cccd6be7bcd158d6eda53113afb6db0ec97e7 /CMakeLists.txt
parentcb89ee49a3cfe9afa5b3338f26810d37e3e43f71 (diff)
downloadsubsurface-5963a15bbd8479a1a3eafcb5fc8bf9a98ccc2769.tar.gz
MXE: add missing Qt5PositioningQuick.dll
Without this the map won't load. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a36b61f07..0cc383d98 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -492,6 +492,13 @@ elseif(CMAKE_SYSTEM_NAME STREQUAL "Windows")
install(TARGETS ${SUBSURFACE_TARGET} DESTINATION ${WINDOWSSTAGING})
install(FILES ${CMAKE_BINARY_DIR}/qt.conf DESTINATION ${WINDOWSSTAGING})
install(DIRECTORY ${CMAKE_INSTALL_PREFIX}/lib/grantlee DESTINATION ${WINDOWSSTAGING})
+
+ if(NOT Qt5Core_VERSION VERSION_LESS 5.11.0)
+ # hack to work around the fact that we don't process the dependencies of plugins
+ # as of Qt 5.11 this additional DLL is needed and it's only referenced in the qml DLLs
+ install(FILES ${_qt5Core_install_prefix}/bin/Qt5PositioningQuick.dll DESTINATION ${WINDOWSSTAGING})
+ endif()
+
if(NOT DEFINED MAKENSIS)
set(MAKENSIS makensis)
endif()