summaryrefslogtreecommitdiffstats
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorGravatar Dirk Hohndel <dirk@hohndel.org>2019-10-14 10:57:28 -0700
committerGravatar Dirk Hohndel <dirk@hohndel.org>2019-10-14 13:37:17 -0700
commit5ce4b3d5eb7ac75c0db38cd6b0c5cd5bdade9448 (patch)
tree55da634369f1f6e28944dd0db3189b8407979fa2 /CMakeLists.txt
parent3df2be5c1646c810000f147b9b14a7e6653e1d9b (diff)
downloadsubsurface-5ce4b3d5eb7ac75c0db38cd6b0c5cd5bdade9448.tar.gz
build-system: Subsurface-mobile now requires Qt 5.11
This is one of the side effects of switching to Kirigami 5.62 - but since we build our mobile versions with Qt 5.12 and Qt 5.13, this really isn't an issue. Signed-off-by: Dirk Hohndel <dirk@hohndel.org>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 43ea39564..478712f46 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -243,7 +243,12 @@ if(ANDROID)
set(CMAKE_FIND_ROOT_PATH "/;${CMAKE_FIND_ROOT_PATH}")
endif()
set(QT_FIND_COMPONENTS Core Concurrent Widgets Network Svg Positioning Quick Location ${QT_EXTRA_COMPONENTS})
-find_package(Qt5 5.9.1 REQUIRED COMPONENTS ${QT_FIND_COMPONENTS} LinguistTools Test QuickTest)
+if (SUBSURFACE_TARGET_EXECUTABLE MATCHES "DesktopExecutable")
+ find_package(Qt5 5.9.1 REQUIRED COMPONENTS ${QT_FIND_COMPONENTS} LinguistTools Test QuickTest)
+else()
+ # Kirigami 5.62 and newer require at least Qt 5.11
+ find_package(Qt5 5.11 REQUIRED COMPONENTS ${QT_FIND_COMPONENTS} LinguistTools Test QuickTest)
+endif()
foreach(_QT_COMPONENT ${QT_FIND_COMPONENTS})
list(APPEND QT_LIBRARIES Qt5::${_QT_COMPONENT})
endforeach()